Image Upload Not Working

I have been trying for hours to create a Formative with images uploaded. I have tried different browsers, different computers, different networks, and I get the same error message each time (see below). I have tried uploading from my computer and from Google Drive. Also, the support link is not working. :frowning: Anyone else having these issues?

Actually, I just noticed the same thing is happening when trying to record audio.

Hi there, sorry you’re experiencing this issue. I’ve noticed a few reports of this in the past and it could mean you have a slow internet connection. If the file you are uploading is quite large then the transfer could timeout.

Which support link are you trying? If it’s the in-app intercom widget please make sure you do not have any ad blockers and/or pop-up blockers enabled, as it could prevent the support widget from opening.

You can also email directly, please make sure you provide the URL you’re trying to upload content on, and as much information as possible (including a screenshot of the entire tab).

Lasty, you could try enabling diagnostics on your account and then attempting to upload content again (capturing the issue for inspection). If you go to Formative and toggle the switch below before attempting the upload, and then notifying me after you experience the problem, I can see what’s going on. Make sure to reload your page after enabling that setting.